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Executive Summary
Members of the iCare Product Management team conducted a usability test of the iCare
Electronic Health Record (EHR), version 2, on 12/10/2019 and 12/16, 2019 in the iCare
Development Center. The purpose of this test was to test and validate the usability of the current
user interface and to provide evidence of the safety enhanced design of the EHR Under Test
(EHRUT).
The iCare EHR has been designed for inpatient and ambulatory clinical documentation,
computerized order entry, and clinical decision-making in medical facilities. This product is also
being utilized in academic environments as a tool for students preparing for careers in nursing and
health information technology. The test cohort included at least one physician, nurse, pharmacist,
health information technician, lab technician, and billing and financial specialist.
The test collected performance data on various tasks required by the Office of the National
Coordinator (ONC) for a Meaningful Use certified EHR. The areas included in this study were:
1. 170.315 a.1 CPOE Medication
2. 170.315 a.2 CPOE Laboratory
3. 170.315 a.3 CPOE Diagnostic Imaging
4. 170.315 a.4 Drug-drug, Drug-Allergy Interactions Checks
5. 170.315 a.5 Demographics
6. 170.315 a.6 Problem List
7. 170.315 a.7 Medication List
8. 170.315 a.8 Medication Allergy List
9. 170.315 a.9 Clinical Decision Support
10. 170.315 a.14 Implantable Devices
11. 170.315 b.2 Clinical Information Reconciliation
Each test participant was selected as new users with little or no formal training on the use of the
iCare EHR. Each participant was given an introductory session covering basic navigation prior to
beginning the test.
The following types of data were collected for each participant:
•
•

Number of tasks successful completed within allotted time without assistance.
Time to complete the tasks
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•
•
•
•

Number and types of errors
Path deviations
Participants verbalizations
Participants satisfaction ratings of the system

The usability tests were conducted as baseline tests for end-user computer competency and an
introduction to the product without formal training. The test administrator did not provide
assistance to the participants in how to complete the tasks. Each test lasted approximately two
hours with a three-hour time limit.
All participant data was de-identified so that no correlation could be made between the
participants and the test results. Following the end of the test period a verbal discussion was
conducted to gather general comments and feedback about the iCare product.
The overall results and feedback gathered from the test, determined that the iCare EHR has been
designed with enough flexibility to support various types of end-user workflows while
maintaining the integrity of the data being entered or presented for clinical decision making. As
functionality is modified or increased based on future input from end-users the design foundation
should not hinder the usability of the application.
Major Findings:
• The design of the user screens remains consistent throughout the application which
supports users to quickly gain a level of proficiency navigating through the system.
• Sections of the application are clearly labeled and navigation is straightforward.
• Menus within the sections/screens of the application apply to the functionality the
section is designed to support.
• In areas important to patient safety, information warnings appear that provide the user
with data needed for decision-making, however the application does not force a
workflow or decision on the user.
• A comparison of menu options available to the end user is based on the permissions of
the user profiles assigned to the user.
• Users reported high satisfaction.
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Areas for Improvement:
• Several configuration options caused confusion by some users. For example, the
setting for e-signatures caused several users to add additional steps when changing
orders.
• On Apple computers running Mac OS, several users were confused by scrolling
direction and the auto-hiding scroll bars.

Introduction
The EHRUT tested for this study was the iCare Electronic Health Record, version 2, for complete
inpatient functionality as required by the Office of the National Coordinator (ONC) for
Meaningful Use certification.
Designed to present medical information to healthcare providers and health information
technicians in hospitals and academic settings, the EHRUT consists of a cloud based design that
supports real-time data capture and presentation within a secured user interface for documenting
and retrieving patient data valuable for clinical decision making and supporting actions required
for patient care. The usability testing attempted to represent realistic exercises and conditions.
The purpose of this study was to test and validate the usability of the current user interface and to
provide evidence of safety enhanced design in the EHR Under Test (EHRUT). To this end,
measures of effectiveness, efficiency and user satisfaction, such as clicks, time on task, errors and
success rate, were captured during the usability testing.

User Centred Design
The staff at iCare.com continues to focus on the human-centered design approach for the iCare
Electronic Health Record (EHR). By focusing on the users, their needs and requirements, and
incorporating required patient safety measures we follow the principles of the ISO standard 9241210:2010.
At iCare, we consider our design process as a collaborative effort that includes input from our
users, as well as other industry subject matter experts, to research, create, test, and release
functionality that is client-centered, function driven, and supports patient safety. User
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requirements are continuously obtained, reviewed, and utilized from the beginning of the design
of functionality within the product, whether it is new functionality under consideration or current
functionality that is to be modified based on user feedback, until the final release process.
The input obtained from users throughout the research, design, and testing processes is what
drives our efforts. The process begins with an idea or a request - we then meet with users that
specialize in the area that the functionality is being designed to support. We ask questions and
take statements focused on goals, workflow, challenges, and measures for success. Following this
type of design process helps ensure that the functionality will meet the needs of our users –
current and future. We strive to have a product that maintains a consistent design that makes it
easy for the user to navigate through the system with a minimum of effort. This consistency of
the design supports our goal to have a product that has a reduced learning curve - each area in the
product follows a similar format, for instance menu placement, once the user becomes familiar
with how to initiate a command or access data in one section of the product, a similar action can
be duplicated in another.
The basic design fundamentals that we adhere to ensures that the iCare EHR is a product that is
accessible, consistent, effective, efficient, and meets its goals based on our user’s duty-motivated
needs.

Intended Users
The iCare system has been designed as a complete EHR for use in inpatient and ambulatory
medical care facilities and as a tool for teaching future health care professionals.

The

iCare EHR is currently being marketed to and used by nurses, doctors, and health
information technicians as well as instructors in academic environments teaching students
that are studying to enter these professions.

Test Method
Participants
A total of ten participants were tested on the EHRUT. There was a mixture of backgrounds and basic
characteristic to provide a high-level cross-section of potential user backgrounds.
Participants were recruited by a combination of invitations and requests to new customers and
applicants for open positions at the company as part of their computer use competency screening
prior to the interview phase of the hiring process.
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Participants were given the opportunity to have a basic orientation and introductory level of
training as the actual end users would have received. Participants were told this testing was to
provide a baseline of each user’s knowledge of EHR navigation and that their scores and
feedback would be used as usability and improvement data.
Below is a table of participants that includes demographics, professional experience, and
computing experience. Participant names were replaced with User IDs so that the individual’s
data could not be connected to their identities.
USER

GENDER

AGE

EDUCATION

ID

01

Male

70-

Master’s

79
02

Female

50-

OCCUPATION/R

PROFESSIONAL

COMPUTER

PRODUCT

OLE

EXPERIENCE

EXPERIENCE

EXPERIENCE

Chief Financial

372

Expert

Some

Officer
Associate

Nurse

120

Average

Oriented

Some college

Health

252

Average

None

59
03

Female

4049

Information
Manager

04

Male

50-

Some college

Lab Technician

180

Good

None

Some college

Lab Technician

264

Good

None

Doctorate

Pharmacy

156

Good

None

60

Expert

None

59
05

Male

5059

06

Male

5059

07

Female

60-

Manager
Associate

69
08

Female

30-

Medical Billing
Specialist

Bachelor’s

Nurse

84

Average

None

Bachelor’s

Medical Billing
Specialist

60

Average

None

Doctorate

Physician

192

Good

Some

39
09

Female

6069

10

Male

3039

NOTE:
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Participants were scheduled from fifteen to thirty minutes per functionality section with five to
ten minute breaks between each area section test.

Test Design
The objective of this test was to uncover areas where the application performed as expected as
well as areas where the application failed to meet the needs of the participants. The data from
this test will serve as a baseline for future tests and updated versions of this application. The
feedback from participants will be included with other suggestions for new or improved
functionality for the product.

During the test, participants were encouraged to interact with each other in order for the facilitators
to gage the type of spontaneous feedback would occur among users. The application
was evaluated for effectiveness, efficiency and satisfaction as defined by the goal of each task to
be completed. Overall, the participants did not report any deviation in understanding the objective
or ability to complete the task within the time allotted.

Tasks
The tasks selected were determined on the needs of usability, user risk, and the ability to report
findings for Meaningful Use reporting. The following areas were prioritized as follows for
testing:
1. Record and Change a Medication Order
2. Record and Change a Laboratory Order
3. Record and Change a Imaging Order
4. Record and Change Patient Demographics
5. Record and Change Problem List
6. Record and Change Medication List
7. Record and Change Medication Allergy List
8. Trigger a drug-drug interaction and drug-allergy alert by entering a new medication order
9. Add, Trigger, and View CDS Interventions.
10. Record Change Implantable Devices list with UDI

ÓCopyright iCare.com, Inc. 2019

7

11. Incorporate CCDA and conduct reconciliation for all three (CCD, Referral Note, Discharge
Summary), generate new CCDA
The test was designed to ensure that a user could enter, access, and/or modify data within areas 1
through 7. For item 8, Clinical Support, the focus was on ensuring that as data was entered or
modified, the proper alerts would appear to ensure the user could make an informed decision.

Risk Assessment
Each task was assessed a risk rating of low, moderate, or high, based on the likelihood of error
combined with the relative patient safety impact of any potential error.
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Task ID Task Description

Patient Safety
Likelihood of
Overall Risk
Impact of
Error
Rating
Error

Criteria 170.315(a)(1) - CPOE Medications
A.1.1

Computerized provider order entry (CPOE) – create medication order

Moderate

High

High

A1.2

Computerized provider order entry (CPOE) – change medication order

Low

High

High

A1.3

Computerized provider order entry (CPOE) – display medication order

Low

Moderate

Moderate

Criteria 170.315(a)(2) - CPOE Laboratory
A2.1

Computerized provider order entry (CPOE) – create laboratory order

Moderate

Moderate

Moderate

A2.2

Computerized provider order entry (CPOE) – change laboratory order

Low

Moderate

Moderate

A2.3

Computerized provider order entry (CPOE) – display laboratory order

Low

Low

Low

Criteria 170.315(a)(3) - CPOE Radiology
A3.1

Computerized provider order entry (CPOE) – create diagnostic imaging order

Moderate

Moderate

Moderate

A3.2

Computerized provider order entry (CPOE) – change diagnostic imaging order

Low

Moderate

Moderate

A3.3

Computerized provider order entry (CPOE) – display diagnostic imaging order

Low

Low

Low

Criteria 170.315(a)(4) - Drug-drug, Drug-allergy Interaction Checks
A4.1

Drug-drug, drug-allergy interaction checks for CPOE - trigger a drug-drug interaction alert

Low

High

Moderate

A4.2

Drug-drug, drug-allergy interaction checks for CPOE - trigger a drug-allergy interaction alert

Low

High

Moderate

A4.3

Drug-drug, drug-allergy interaction checks for CPOE - adjust drug-drug severity alert threshold Moderate

High

High

Criteria 170.315(a)(5) - Demographics
A5.1

Demographics - enter

Low

Moderate

Moderate

A5.2

Demographics - change

Low

Low

Low

A5.3

Demographics - display

Low

Low

Low

Criteria 170.315(a)(6) - Problem List
A6.1

Problem list - enter problem

Moderate

Moderate

Moderate

A6.2

Problem list - change problem

Moderate

Moderate

Moderate

A6.3

Problem list - display active and historical problem list

Low

Moderate

Moderate

Criteria 170.315(a)(7) - Medication List
A7.1

Medication list - enter medication list order

Moderate

High

High

A7.2

Medication list - change medication list order

Low

High

High

A7.3

Medication list - display active and historical medication list

Low

Moderate

Moderate

Criteria 170.315(a)(8) - Medication Allergy List
A8.1

Medication allergy list - enter medication allergy

Moderate

High

High

A8.2

Medication allergy list - change medication allergy

Low

High

High

A8.3

Medication allergy list - display active and historical medication allergy list

Low

High

High

Criteria 170.315(a)(9) - Clinical Decision Support
A9.1

Clinical decision support (CDS) - add a CDS intervention

Moderate

High

High

A9.2

Clinical decision support (CDS) - trigger a CDS intervention

Low

High

High

High

High

High

High

Moderate

Moderate

A9.3
A9.4
A9.5

Clinical decision support (CDS) - view the intervention/resource information using the
High
Infobutton standard for data elements in the problem list, medication list, and demographics
Clinical decision support (CDS) - trigger and view CDS intervention information and resources
Moderate
from transition of care
Clinical decision support (CDS) - access the following attributes for one of the triggered CDS
interventions/resources: bibliographic citation, developer, funding source, release/revision Low
date

Criteria 170.315(a)(14) - Implantable Device List
A14.1

Implantable device list - enter implantable device

Low

Moderate

Moderate

A14.2

Implantable device list - change implantable device

Low

Moderate

Moderate

A14.3

Implantable device list - display implantable device list

Low

Moderate

Moderate

Criteria 170.315(b)(2) - Clinical Information Reconciliation and Incorporation
B2.1

Clinical information reconciliation and incorporation - medication list reconciliation

Moderate

High

High

B2.2

Clinical information reconciliation and incorporation - create CCDA with reconciled data

High

High

High
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Procedure
The tests were facilitated by the iCare Meaningful Use Project Manager and senior management. To
ensure consistency in communication to all participants, the same staff member delivered the same
level of minimal product training in a group environment to all participants. To ensure that proper
attention was given to the test groups, the number or participants was kept to a small number for
each session.
Participants were instructed to perform each given task as quickly as possible and that if they
experienced uncertainty in how to perform a given task to alert the facilitator as soon as possible.
Only questions requesting clarification of a task were addressed and only after the specific task
section was completed could group discussion occur.
Although each task was timed, the participants were allowed to complete each section, without
having the time limits announced. It was decided that this would result in fewer mistakes as a
result of stress. The task time was recorded once the participant indicated they had successfully
completed the task.

Test Locations
The test areas were quiet and included individual workstations for each participant. Three of the
participants were tested in a group environment on a college campus, two were tested at the iCare
facility in separate rooms, and one participant was tested via a webcast hosted by the project manager
while the participant sat at home. These various locations were chosen to simulate real working
environments by potential users.

Test Environment
The application has been designed as a cloud (web) based product which allows the user to use it
via any type of computer or mobile device. The application defaults were set by the iCare team the participants were not given the administrative permission to make changes to the default
settings unless required by a test segment. Each user was allowed to select the web browser that
he or she was most comfortable with or being used by the company that was allowing the test to
occur at their site – only two Internet browsers were selected for the test groups.
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Test Forms and Tools
Two forms were used for testing:
1. The test form consisted of a list of patients with problems, allergies, orders (medications,
labs, and radiology), and progress notes.
2. Test Usability Scoring Sheet
Examples of these forms can be found in the Appendix section.

Participants Instructions
The testing was introduced following two specific scenarios:
1. As an introduction to functionality testing to new employees.
2. As a baseline evaluation for new users to provide testing and feedback on the product
design.
The following statement was made to both groups:
Thank you for volunteering to perform new user testing on the iCare EHR. Your ability to perform
the tasks presented in this test are not a reflection on your knowledge of computer software, the
results of this test will assist us in gaining knowledge on the ease of use of the product and identify
any areas in the design that require modifications or improvement. You will be given a patient record
to use for entering, changing, and accessing data within the record. In some cases, based on your
entry, we are looking to see how the application responses, such as with warning messages or the
requirement of you to perform another step to complete the task you have been assigned.
If you face any issues or have general questions regarding the objective of the task, please feel
free to ask me, however be aware that I will not encourage or participate in a discussion of how
to perform a task until that task has been completed or the task could not be performed.

Usability Metrics
The goal is for users to interact with the system effectively, efficiently, and with an acceptable
level of satisfaction. To this end, metrics for effectiveness, efficiency and user satisfaction were
captured during the usability testing.
The goals of the test were to assess:
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1. Effectiveness of the iCare EHR by measuring participant success rates and errors
2. Efficiency of the iCare EHR by measuring the path deviations
3. Satisfaction with the iCare EHR by measuring ease of use ratings

Data Scoring
The following table provides information regarding how the tasks were scored.
Measures

Rationale and Scoring

Effectiveness:

A task was counted as a “Success” if the participant was able to

Task Success

achieve the correct outcome, without assistance, within the time
allotted on a per task basis.
The total number of successes were calculated for each task and
then divided by the total number of times that task was attempted.

Effectiveness:

If the participant abandoned the task, did not reach the correct

Task Failure

answer or performed it incorrectly, the task was counted as a
“Failure.”
The total number of errors was calculated for each task and then
divided by the total number of times that task was attempted.

Efficiency:

The participant’s path (i.e., steps) through the application was

Task Deviations

recorded. Deviations occur if the participant, for example, went
to a wrong screen, clicked on an incorrect menu item, followed
an incorrect link, or interacted incorrectly with an on-screen
control. This path was compared to the optimal path.

Satisfaction:

Participant’s subjective impression of the ease of use of the

Task Rating

application was measured by administering a simple post-task
question. After each task, the participant was asked to rate
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“Overall, this task was:” on a scale of 1 (Very Difficult) to 5
(Very Easy).

Results
Data Analysis and Reporting
The results of the usability test were calculated according to the methods specified in the
Usability Metrics section above.
Participants who failed to follow session and task instructions had their data excluded from the
analyses. [NOTE: All participants followed session and task instructions – therefore no
exclusions were required.]
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Task ID

Task Description

Task
Task
Success
Success
Std Dev
Mean (%)
(%)

Task Path
Task Path Task Time
Deviation
Deviation Mean
Observed
Optimal # (seconds)
#

Task Time Task Time
Task Time
Deviation Deviation Task
Standard
Mean
Mean
Errors
Deviation
Observed Optimal
Mean(%)
(seconds)
Seconds Seconds

Task
Task
Rating
Errors Std
Scale
Dev %)
Type

Task
Rating

Task
Rating
Standard
Deviation

Criteria 170.315(a)(1) - CPOE Medications
A.1.1

Computerized provider order entry (CPOE) – create
100
medication order

0

18

18

115

19

19

80

0

0

Likert

4.9

0.32

A1.2

Computerized provider order entry (CPOE) – change
100
medication order

0

18

18

104

19

19

70

0

0

Likert

4.8

0.42

A1.3

Computerized provider order entry (CPOE) – display
100
medication order

0

9

9

61

7

7

40

0

0

Likert

4.9

0.32

Criteria 170.315(a)(2) - CPOE Laboratory
A2.1

Computerized provider order entry (CPOE) – create
100
laboratory order

0

10

10

124

22

22

72

0

0

Likert

4.7

0.48

A2.2

Computerized provider order entry (CPOE) – change
100
laboratory order

0

11

11

125

23

23

80

0.1

0.32

Likert

4.6

0.52

A2.3

Computerized provider order entry (CPOE) – display
100
laboratory order

0

8

8

57

10

10

48

0

0

Likert

4.6

0.52

Criteria 170.315(a)(3) - CPOE Radiology
A3.1

Computerized provider order entry (CPOE) – create
100
diagnostic imaging order

0

14

14

155

32

32

87

0.2

0.42

Likert

4.5

0.53

A3.2

Computerized provider order entry (CPOE) – change
90
diagnostic imaging order

31.62

13

13

142

23

23

81

0.1

0.32

Likert

4.2

1.23

A3.3

Computerized provider order entry (CPOE) – display
100
diagnostic imaging order

0

8

8

58

9

9

47

0

0

Likert

4.6

0.52

Criteria 170.315(a)(4) - Drug-drug, Drug-allergy Interaction Checks
A4.1

Drug-drug, drug-allergy interaction checks for CPOE
90
- trigger a drug-drug interaction alert

31.62

16

16

173

30

30

120

0.2

0.42

Likert

4.3

1.25

A4.2

Drug-drug, drug-allergy interaction checks for CPOE
90
- trigger a drug-allergy interaction alert

31.62

16

16

176

35

35

120

0.2

0.42

Likert

4.4

1.26

A4.3

Drug-drug, drug-allergy interaction checks for CPOE
90
- adjust drug-drug severity alert threshold

31.62

24

23

158

20

20

107

0.2

0.42

Likert

4.5

1.27

Criteria 170.315(a)(5) - Demographics
A5.1

Demographics - enter

90

31.62

25

25

313

53

53

214

0.2

0.42

Likert

4.6

1.27

A5.2

Demographics - change

90

31.62

19

19

316

50

50

215

0.2

0.42

Likert

4.5

1.27

A5.3

Demographics - display

90

31.62

17

19

135

41

41

97

0.2

0.42

Likert

4.5

1.27

Criteria 170.315(a)(6) - Problem List
A6.1

Problem list - enter problem

100

0

13

13

132

23

23

90

0

0

Likert

4.7

0.48

A6.2

Problem list - change problem

100

0

14

14

111

19

19

87

0

0

Likert

4.8

0.42

A6.3

Problem list - display active and historical problem
100
list

0

8

8

77

14

14

60

0

0

Likert

4.8

0.42

Criteria 170.315(a)(7) - Medication List
A7.1

Medication list - enter medication list order

100

0

19

19

153

19

19

120

0

0

Likert

4.8

0.42

A7.2

Medication list - change medication list order

100

0

13

13

110

26

26

80

0

0

Likert

4.9

0.32

A7.3

Medication list - display active and historical
medication list

100

0

10

10

66

16

16

46

0

0

Likert

5

0

Criteria 170.315(a)(8) - Medication Allergy List
A8.1

Medication allergy list - enter medication allergy

90

31.62

15

15

164

31

31

110

0.2

0.42

Likert

4.5

1.27

A8.2

Medication allergy list - change medication allergy

90

31.62

12

12

127

24

24

87

0.1

0.32

Likert

4.4

1.27

A8.3

Medication allergy list - display active and
historical medication allergy list

90

31.62

8

8

88

18

18

62

0.2

0.42

Likert

4.5

1.27

90

31.62

12

12

104

16

16

60

0.1

0.32

Likert

4.6

1.27

90

31.62

12

12

97

21

21

65

0.1

0.32

Likert

4.6

1.27

90

31.62

12

12

66

11

11

24

0.1

0.32

Likert

4.3

1.34

90

31.62

16

16

145

13

13

118

0.1

0.32

Likert

4.3

1.34

90

31.62

7

7

39

7

7

22

0.1

0.32

Likert

4.3

1.34

Criteria 170.315(a)(9) - Clinical Decision Support

A9.1

A9.2

A9.3

A9.4

A9.5

Clinical decision support (CDS) - add a CDS
intervention and/or reference resource for each of
the required elements and combination of
elements
Clinical decision support (CDS) - trigger the CDS
interventions/resources added using the applicable
data elements from each of the required elements
and combination of elements
Clinical decision support (CDS) - view the
intervention/resource information using the
Infobutton standard for data elements in the
problem list, medication list, and demographics
Clinical decision support (CDS) - trigger and view
CDS intervention information and resources from
transition of care
Clinical decision support (CDS) - access the
following attributes for one of the triggered CDS
interventions/resources: bibliographic citation,
developer, funding source, release/revision date

Criteria 170.315(a)(14) - Implantable Device List
A14.1

Implantable device list - enter implantable device

90

31.62

13

13

141

20

20

94

0.1

0.32

Likert

4.5

1.27

A14.2

Implantable device list - change implantable device 90

31.62

12

12

91

17

17

61

0.1

0.32

Likert

4.6

1.27

A14.3

Implantable device list - display implantable device
90
list

31.62

11

11

81

14

14

59

0.1

0.32

Likert

4.6

1.27

Criteria 170.315(b)(2) - Clinical Information Reconciliation and Incorporation
B2.1

Clinical information reconciliation and
incorporation - medication list reconciliation

90

31.62

32

32

273

50

50

180

0.1

0.32

Likert

4.3

1.25

B2.2

Clinical information reconciliation and
incorporation - create CCDA with reconciled data

90

31.62

12

12

92

19

19

60

0.1

0.32

Likert

4.5

1.27
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Discussion of the Findings
1. Effectiveness
Based on a combination of the testing results and the feedback from the participants it has
been determined that the iCare EHR is an application that supports a workflow that
provides an effective means for placing orders pertaining to patient care, documenting
this care in a manner that is easy to understand, and accessing information stored in the
patient’s chart.
2. Efficiency
According to the findings of the test, combined with feedback from the test participants,
the cloud based technology of the iCare EHR provides the an efficient process for
documenting patient care, placing orders (medication, laboratory, and
radiology/imaging), as well as accessing and modifying the data. The information input
into the system initiates an action or can be accessed in real time – reducing the margin
for error and increasing patient care productivity.
3. Satisfaction
The test participants reported that they found the iCare application as an easy to
understand and use product. Most area patient chart areas in application are clearly
labelled and due to the stable design (for instance the placement and functionality of the
Action button) the application reduces the learning curve for using the software and
supports a consistent means of performing most actions.
4. Error Rate and Deviations
Each participant was allowed to attempt to complete a task for a minimum of two
attempts or make the self-decision to stop trying before the task completion was
considered a failure. [NOTE: No participants made the decision to stop attempting to
complete a task; when a deviation occurred the participants, on their own accord, made
the decision to stop, rethink the path that they were following and started the task again.]
5. Major Findings
The participants reported
•

That the design of the user screens remains consistent throughout the application
which supports the ability for users to quickly gain a level of proficiency
navigating through the system.
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•

Most sections within the patient chart labelled based on the data that is contained
in the screens or the functionality that is to be performed.

•

Menus presented from the Action button apply to the functionality the section is
designed to support – this allowed the participants to feel as though the software
was easy to learn without extensive training.

•

The participants felt that the iCare EHR was designed with patient safety in mind
– The pop-up intervention screens provided the user with data needed for
decision-making, however the application does not force a workflow or decision
on the user.

•

The user liked the fact that the menu options available to the end user is based on
the permissions of the user profiles assigned to the user. In this way, the software
can be configured to address the needs and roles of the users.

6. Areas for Improvement
The participants provided the following feedback regarding areas of possible
improvement:
•
•

The options that are available to the end user are controlled by the user
profile configuration options however, it would be useful if the configurations could
be made apparent to new users.
There is a need to include vital sign interventions in the Notification List area of
the software instead of making the user open the patient chart to see an
intervention. This type of notification is already present for critical lab results.

Appendices
A. Sample recruiting Screener
Recruiting Script for Recruiting Participants
Hello, I am representing iCare.com. We are recruiting individuals to participate in a usability study for
our electronic health record. We would like to ask you a few questions to see if you qualify and if would
like to participate. This should only take a few minutes of your time. This is strictly for research
purposes. Can I ask you a few questions?
1. Have you participated in a focus group or usability test in the past 6 months?
2. Which of the following best describes your age? [23 to 39; 40 to 59; 60 - to 74; 75 and older]
3.. Do you require any assistive technologies to use a computer?
Professional Demographics
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4. What is your current position and title? (Must be healthcare provider)
¨ RN: Specialty
¨ Physician: Specialty _
¨ Resident: Specialty
¨ Administrative Staff
¨ Other
5. How long have you held this position?
6. Describe your work location (or affiliation) and environment? [e.g., private practice, health system, government
clinic, etc.]
7. Which of the following describes your highest level of education? [e.g., high school graduate/GED, some
college, college graduate (RN, BSN), postgraduate (MD/PhD), other (explain)]
Computer Expertise
8. Besides reading email, what professional activities do you do on the computer? [e.g., access EHR, research;
reading news; shopping/banking; digital pictures; programming/word processing, etc.]
9. About how many hours per week do you spend on the computer? [ e.g., 0 to 10, 11 to 25, 26+ hours per week]
10. What computer platform do you usually use? [e.g., Mac, Windows, etc.]
11. What Internet browser(s) do you usually use? [e.g., Firefox, IE, AOL, etc.]
12. In the last month, how often have you used an electronic health record?
13. How many years have you used an electronic health record?
14. How many EHRs do you use or are you familiar with?
15. How does your work environment patient records?
¨ On paper
¨ Some paper, some electronic
¨ All electronic
Contact Information
Those are all the questions I have for you. Your background matches the people we're looking for.
Would you be able to participate on [date, time]?
May I get your contact information?
§ Name of participant:
§ Address:
§ City, State, Zip:
§ Daytime phone number:
§ Evening phone number:
§ Alternate [cell] phone number:
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B. Participant Demographics
The participants in this study were selected based on their availability and expressed interest in
using the iCare EHR.

C. Nondisclosure Agreement and Informed Content

Non-Disclosure Agreement
THIS AGREEMENT is entered into as of _ _, 2019, between (“the Participant”) and the testing
organization iCare.com, Inc. located 401 E. Las Olas Blvd., Ste 1400, Fort Lauderdale, FL 33301
The Participant acknowledges his or her voluntary participation in today’s usability study may bring the
Participant into possession of Confidential Information. The term "Confidential Information" means all
technical and commercial information of a proprietary or confidential nature which is disclosed by Test
Company, or otherwise acquired by the Participant, in the course of today’s study.
By way of illustration, but not limitation, Confidential Information includes trade secrets, processes,
formulae, data, know-how, products, designs, drawings, computer aided design files and other computer
files, computer software, ideas, improvements, inventions, training methods and materials, marketing
techniques, plans, strategies, budgets, financial information, or forecasts.
Any information the Participant acquires relating to this product during this study is confidential and
proprietary to iCare.com, Inc. and is being disclosed solely for the purposes of the Participant’s
participation in today’s usability study. By signing this form the Participant acknowledges that will not
disclose this confidential information obtained today to anyone else or any other organizations.
Participant’s printed name:
Signature:
Date:
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Informed Consent
iCare.com, Inc. would like to thank you for participating in this study. The purpose of this study is to evaluate an
electronic health records system. If you decide to participate, you will be asked to perform several tasks using the
prototype and give your feedback. The study will last about 60 minutes. At the conclusion of the test, you will be
compensated for your time.
Agreement
I understand and agree that as a voluntary participant in the present study conducted by iCare.com, Inc. I am free
to withdraw consent or discontinue participation at any time. I understand and agree to participate in the study
conducted by the iCare.com, Inc..
I understand and agree that the purpose of this study is to make software applications more useful and usable in
the future.
I understand and agree that the data collected from this study may be shared with outside of iCare.com, Inc. and
iCare.com, Inc.’s client. I understand and agree that data confidentiality is assured, because only de- identified
data – i.e., identification numbers not names – will be used in analysis and reporting of the results.
I agree to immediately raise any concerns or areas of discomfort with the study administrator. I understand that I
can leave at any time.
Please check one of the following:
¨ YES, I have read the above statement and agree to be a participant.
¨ NO, I choose not to participate in this study.
Signature:
Date:
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D. Moderator’s Guide
Administrator ___________________
Data Logger ___________________
Date
___________________
Time
___________________
Participant # ___________________
Location
___________________
Prior to testing
§ Confirm schedule with Participants
§ Ensure EHRUT lab environment is running properly
§ Ensure lab and data recording equipment is running properly
Prior to each participant:
§ Reset application
§ Start session recordings with tool
Prior to each task:
§ Reset application to starting point for next task
After each participant:
§ End session recordings with tool
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Orientation (X minutes)
Thank you for participating in this study. Our session today will last XX minutes. During that time you will take a
look at an electronic health record system.
I will ask you to complete a few tasks using this system and answer some questions. We are interested in how
easy (or how difficult) this system is to use, what in it would be useful to you, and how we could improve it. You
will be asked to complete these tasks on your own trying to do them as quickly as possible with the fewest
possible errors or deviations. Do not do anything more than asked. If you get lost or have difficulty I cannot
answer help you with anything to do with the system itself. Please save your detailed comments until the end of a
task or the end of the session as a whole when we can discuss freely.
I did not have any involvement in its creation, so please be honest with your opinions.
The product you will be using today is describe the state of the application, i.e., production version, early
prototype, etc. Some of the data may not make sense as it is placeholder data.
We are recording the audio and screenshots of our session today. All of the information that you provide will be
kept confidential and your name will not be associated with your comments at any time.
Do you have any questions or concerns?
Preliminary Questions (X minutes)
What is your job title / appointment?
How long have you been working in this role?
What are some of your main responsibilities?
Tell me about your experience with electronic health records.
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Usability Testing Tasks and Paths
1

CPOE Order Medication §170.314(a)(1)
Create Order
Login-> Click No in the Pop up-> Type R83860-> Click Search->Double Click on Patient Record-> On
Order Screen Left lower Panel Click on + sign Pharmacy Medications-> Click Unit Dose Medications> Type Aceta… -> Select ACETAMINOPHEN 325mg -> Select Dose 325 mg-> Frequency: Type BID and
Select from drop down-> Click Perform Drug Check-> Accept Order-> Click on right upper corner
User Name -> Click Log out

2

Change Order
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> On Order
Screen Select Order Acetaminophen 325 mg-> From Actions menu select Change -> Frequency: Type
DAILY and Select DAILY PRN from drop down-> Click Perform Drug Check-> Accept Order-> Log out

3

Display Order with Change
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> On Order
Screen Point the Mouse o Order column content and view the content-> Log out

4

CPOE Order Laboratory §170.314(a)(2)
Create Order
Login-> Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home->
On Order Screen Left lower Panel Click on Laboratory-> Type CBC in Available Lab Test field -> Select
CBC Profile->Accept Order-> Log out

5

Change Order
Login-> Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home->
On Order Screen select Lab CBC Profile-> Select Change from Actions Menu-> Type LIPID in Available
Lab Test field -> Select Lipid Profile->Accept Order-> Log out

6

Display Order with Change
Login->Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home->
On Order Screen point the cursor on the content for Lab Order in Order column and view the
content-> Log out
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7

CPOE Order Imaging Order §170.314(a)(3)
Create Order
Login->Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home->
On Order Screen Left lower Panel Click on Imaging ->Select Imaging type(CT Scan)->select Imaging
Procedure(CT ABD & PELVIS W W/O CONTRAST) ->Select reason for study->Select Date of Desired>Select category-> Click on Save button->Log out

8

Change Order
Login->Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> on
Orders screen select Imaging order->From Action menu select change->Change Imaging type as
Mammography ->Save->log out

9

Display Order with Change
Login->Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home->
On Order Screen point the cursor on the content for Imaging order in Order column and view the
content-> Log out

10

Drug-Drug, Drug- Allergy Intervention §170.314(a)(4)
Trigger a Drug-Drug Interaction
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> On Order
Screen Left lower Panel Click on + sign Pharmacy Medications-> Click Unit Dose Medications-> Type
Warfarin.. -> Select Warfarin Tab -> Dose 2.5 mg-> Frequency: Type BID and Select from drop
down-> Click Perform Drug Check-> View the Drug-Drug Interaction information-> View the legend
for Severity level and Note the level of Severity-> Cancel and Log out

11

Trigger a Drug-Allergy Interaction alert
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> On Order
Screen Left lower Panel Click on + sign Pharmacy Medications-> Click Unit Dose Medications-> Type
Ibuprofen.. -> Select Ibuprofen12 Tab -> Dose 400 mg-> Frequency: Type BID and Select
from drop down-> Click Perform Drug Check-> View the Drug-Allergy interaction alert for
Ibuprofen-> Cancel and Log out
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12

Adjust Drug-Drug Interaction Severity for the Displayed Drug
Login-> Press OK on the Pop up screen-> Click on Admin-> Click on Medication & Pharmacy -> Click
on Drug Interaction Severity-> Check the Check box for option ' Severe - Do Not Take These Drugs
Together' -> Click Save
Click on the Patient Chart shown next to Home-> On Order Screen Left lower Panel Click on + sign
Pharmacy Medications-> Click Unit Dose Medications-> Type Warfarin.. -> Select Warfarin Tab ->
Dose 2.5 mg-> Frequency: Type BID and Select from drop down-> Click Perform Drug Check-> There
will be no Drug-Drug interaction alert.: See the text No Interaction..-> Cancel and Log out

13

Demographics §170.314(a)(5)
Record
Enter User Name and Password and Click Login-> Click + Sign next to Home and Select Register->
Enter
First Name : MERVIN,
Last Name : WILMAN
DOB:
06/01/1967
Select the following
Gender: Male
Race:
White
Ethnicity: Not Hispanic or Latino
Preferred Language: English
Do You Think Yourself as: Straight or Heterosexual
What is your current Gender Identity: Male
Click Save
Click Home Tab-> enter Name WILMAN,MERVIN-> Click Search-> Double click the record-> Click
Patient Info Tab-> Click Death Info from lower section-> Type Cardiac Arrest in Preliminary cause of
Death-> Enter Date; Current Date -> Click Save -> Log out

14

Change
Enter User Name and Password and Click Login-> Enter WILMAN,MERVIN and Search->
Double click on the record-> Click Patient Info-> and Change
First Name : CATHERINE,
Last Name : MERVIN
DOB:
06/01/1992
Select the following
Gender: Female
Race:
Asian
Ethnicity: Hispanic or Latino
Preferred Language: Spanish
Do You Think Yourself as: Don't Know
What is your current Gender Identity: Female
Cause of Death: Respiratory Arrest
Date Of Death: 12/12/2019
Click Save-> Log out
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15

Display
Enter User Name and Password and Click Login-> Enter MERVIN,CATHERINE and Search-> Double
click on the record-> Click Patient Info->
View the data
First Name : CATHERINE,
Last Name : MERVIN
DOB:
06/01/1992
Select the following
Gender: Female
Race:
Asian
Ethnicity: Hispanic or Latino
Preferred Language: Spanish
Do You Think Yourself as: Don't Know
What is your current Gender Identity: Female
Cause of Death: Respiratory Arrest
Date Of Death: 12/12/2019
Log out

16

Problem List §170.314(a)(6)
Create Problem List
Login->Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to
Home-> Select Problems tab ->Go to Action Menu->select Create New Problem->Type
problem(Fever)-> Click on search -> select Fever 106 degrees F or over ->Click on OK ->
Select problem status-> click on OK ->Log out

17

Change Problem List
Login-> Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to
Home-> Select Problems tab ->Select added problem ->Go to Action Menu->select
Change Problem->Click on edit icon next to problem name->Type problem(Headache)->
Click on search -> select Headache above the eye region ->Click on OK -> Change
problem status-> click on OK ->Log out

18

Display Problem List with Change
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> On
Problem Screen point the cursor on the content for Probelm view content->Log Out
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19

Medication List §170.314(a)(7)
Create Medication List
Login->Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Select
Meds tab ->Go to Action Menu -> Select New Medication-> Type Acetamin.. -> Select Dose 325 mg> Frequency: Type BID and Select from drop down-> Click Perform Drug Check-> Accept Order-> Go
to Orders->Select Medication Order-> Go to Action->Select Sign Selected->Accept Order->Enter Esignature(123456)->Click on OK button->Go to Meds tab->Verify Medication is displayed->Log Out

20

Change Medication List
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Select
Meds tab ->Go to Action Menu -> Select Change >Change Frequency: type Daily and select from
drop down ->Click perform Drug Check->Accept Order->Log Out

21

Display Medication List
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Select
Meds tab ->hover on Meds order content will display for meds order->Log Out

22

Medication Allergy List §170.314(a)(8)
Create Allergy List
Login-> Type R83860-> Click Search->Double Click on Patient Record-> Select Allergy tab >Go to Action Menu ->Click on Add Allergy->Type IBUPROFEN and select same from
National Drug File-Trade Name>select Obeserved->select nature of reaction (Allergy)>Select Severity (Moderate)->Select Reaction date->Select Sign/Symptoms(Hives)Drag to
the Selected Symptoms box select Date->Enter Comments->Click on OK ->Log Out

23

Change Allergy List
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Select
Allergy tab ->Go to Action Menu ->Click on Edit Allergy->Edit Severity (High)->Click on ok->Log Out

24

Display Allergy List
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Select
Allergy tab->hover on Allergy order content will display for Allergy ->Log Out
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Clinical Decision Support §170.314(a)(9)
25

Add a CDS intervention
1.Open the Admin Screen - Clinical Reminder and Select current user
2. Search and select the following reminder for the elements and click on the right arrow
Problem list: HbA1c for Diabetes
Medication list: WARFARIN
At least one Demographic:
Pneumococcal PPSV23(Pneumovax) for age > 65
Laboratory Test: Control Your Cholesterol
Vital Signs: Body Mass Index >25
Medication Allergy List: Select Penicillin Allergy from Allergy screen
And a combination of at least 2 of the elements listed above (Problem & Lab) - Blood Pressure >=
140/90 mmHg AND Race = Black or African American
Click Apply

26

Trigger a CDS intervention
From Problem Screen Add Problem- Diabetes one ICD (ICD 10 8-13)
View the cover sheet after refresh
Order Screen_ Order WARFARIN and Sign
View the Cover sheet after Refresh"
Patient Info_ enter/edit DOB 1952 (Age > 65)
View the Cover sheet after Refresh
Home _ Laboratory Screen_ Select Result Entry from Actions screen and Search Test Patient 1 by
Admission Date
Select the Test Patient 1 (double click the record)
Direct Entry_Test_Cholesterol LDL
Add result > 99 , Provider , Date and Time and save.
View the Cover sheet after Refresh
Vital Signs Screen_ Add Height 177 cm and Height 92 kg
View the Cover sheet after Refresh
Click on the Posting icon next Patient Name, which will have alphabet 'A' shown.
View the Medication Allergy Name in the Pop up screen.
For test patient 2
Add Vitals - Blood Pressure = 140/90
On patient info, set Race to Black or African American
View the Cover Sheet alert

27

View CDS intervention Information and Resources
Open Reminder screen- Click on the Clock icon near Patient Name or Reminder Tab
Select HbA1c for Diabetes and view the maintenance from view menu.
Click on the URL for the details.
Open Reminder screen- Click on the Clock icon near Patient Name or Reminder Tab
Select WARFARIN and view the maintenance from view menu.
Click on the URL for the details.
Open Reminder screen- Click on the Clock icon near Patient Name or Reminder Tab
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Select Pneumococcal PPV23 and select Reminder Inquiry from View Menu
and Click on the URL provided.

27

Trigger and view CDS intervention from transition of care
Login-> trigger the CDS interventions/resources based on data elements in the problem list,
medication list, and medication allergy list by incorporating patient information from a transition of
care/referral summary / click infobutton / Select Test Patient 3 (Inpatient) / Link the same
document with Test Patient 3
1. Reconciliation- Reconcile Problem List, Medication List, Allergy List
2. Sign the reconciled medication order from Orders Screen
View Cover sheet for Test Patient 3
a. Click the Posting ICON with letter 'A' to view the reminder triggered by the transition of care
b. View the HbA1c for Diabetes, WARFARIN reminders on Cover Sheet View intervention resources
and attributes

28

Access the following attributes for one of the triggered CDS
interventions/resources: bibliographic citation, developer, funding source,
release/revision date
Reminder screen- Select HbA1c for Diabetes and click on Reminder Maintenance from View menu
and click on the URLs shown for Bibliographic citation, Developer, Funding Source and
Release/revision date one by one

29

Implantable Devices List §170.314(a)(14)
Record UDI
Enter User Name and Password and Click Login-> Type R83860-> Click Search->Double Click on
Patient Record-> Click Patient Info tab ->Click on Actions and select Implantable Devices->Click on
'Add' button-> copy and paste (01)00643169007222(17)160128(21)BLC200461H in the UDI field->
Click Verify FDA -> Enter Implant Date 09/11/2017-> Click Save -> Close screen ->Log out

30

Change UDI
Enter User Name and Password and Click Login-> Type R83860-> Click Search->Double Click on
Patient Record-> Click Patient Info tab ->Click on Actions and select Implantable Devices->Select the
record from the grid-> Change the Implant Date to 11/08/2019-> Click Save->Close screen ->Log out

31

Access UDI
Enter User Name and Password and Click Login-> Type R83860-> Click Search->Double Click on
Patient Record-> Click Patient Info tab ->Click on Actions and select Implantable Devices->Select the
record from the grid-> View the record with implant date 11/08/2019-> Click Cancel->Log out
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Clinical Information Reconciliation and Incorporation §170.314(b)(2)
32

Medication List Reconciliation
Login ->Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Click Med
tab-> Click Action Menu and select Create Reconcile List-> Select the file from the Grid shown->
Select CLINDAMYCIN from left panel, drag and drop to right side first grid-> Frequency type BID ->
Select BID-> Click Perform Drug check button-> Click Accept-> Click Actions Menu-> Select Complete
Reconciliation-> Click Accept Order->in eSignature field type 123456 and press Accept->Press OK>Log out

33

Create CCDA with Reconciled data
Login-> Press OK on the Pop up screen-> Click on the Patient Chart shown next to Home-> Click
Reports tab-> Click Clinical Summary-> Select Continuity of Care-> Select the Date-> Log out

Each participant was taken to the starting point of the each task and after the task completion the
Success with three options as above was recorded. The time taken and the comments were also
recorded as per the format above.
Each Task had the Optimal Path defined and it recorded if the participant followed the correct path
or had minor or major deviation as shown in the format above.
Observed Comments/verbalizations were also recorded. Participant rated each task as per Likert
scale. From Very Difficult(1) to Very Easy(5)
The tasks selected for this test are based on the criteria required for the iCare EHR to obtain
certification as a completed inpatient EHR. The product functionality has been designed to allow
the user to select a menu command from the “Action” button or select from a set of menu options
that are always visible on screen that has been selected. The tasks are reflected on the screen that is
labelled by a tab for the item to be found such as Orders, Medications, etc. Once the user selects
the area they wish to work in, the Action button menu items listed are for the screen the user has
selected.
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Below are samples of the optimal path for navigating through the application.
Record Laboratory Order
Orders Tab -> Write Orders->Laboratory -> Available Lab Tests Field -> Search and Select LDL> Complete Fields (Collection Sample, Collection Date, etc) -> Click OK Button
Record Medication Allergy List
Allergies Tab -> Click Actions Button -> Select Add Allergy -> Select Observed/Historical >Enter Allergy Name (Penicillin) and search -> Select Penicillin from list-> Select Nature of
Reaction -> Enter Severity -> Enter Reaction Date-> Select Sign/Symptoms drag and drop and
enter date -> Add comment -> Click OK Button
Drug-Drug, Drug- Allergy List Interventions
The user will follow the process for ordering a medication, however in order to place the order,
first the user must click a button labelled “Perform Drug Check” which will check drug-drug
interaction, medication allergies, dosage limits, and drug order duplications.
Orders Tab -> Write Orders-> Pharmacy Orders-> Unit Dose Medication->Enter WARFARIN and
Select -> Complete Fields from drop down menus (Dosage, Route, Frequency, Priority)-> Click
Perform Drug Check Button -> Order Check Screen will appear for review with Drug-Drug
interaction and Drug- allergy alerts and intervention. The user has the opportunity to Cancel or
Accept the Order.

Final Questions (X Minutes)
What was your overall impression of this system?
What aspects of the system did you like most?
What aspects of the system did you like least?
Were there any features that you were surprised to see?
What features did you expect to encounter but did not see? That is, is there anything that is missing
in this application?
Compare this system to other systems you have used.
Would you recommend this system to your colleagues?
Administer the SUS
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E. System Usability Scale Questionnaire
1. I think that I would like to use this system frequently

1

2

3

4

5

3.I thought the system was easy to use

1

2

3

4

5

4.I think that I would need the support of a technical
person to be able to use this system

1

2

3

4

5

5.I found the various functions in this system were well
integrated

1

2

3

4

5

6.I thought there was too much inconsistency in this
system

1

2

3

4

5

7.I would imagine that most people would learn to use
this system very quickly

1

2

3

4

5

8.I found the system very cumbersome to use

1

2

3

4

5

9.I felt very confident using the system

1

2

3

4

5

10. I needed to learn a lot of things before I could get
going with this system

1

2

3

4

5
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